Commande Cisco pour routeur

 


Aujourd'hui je vous propose des commandes pour les routeurs Cisco, qui peuvent vous aider




Ajouter un mot de passe au telnet
Routeur> enable
Routeur# conf t
Router(config)# line vty 0 4
Router(config-line)# login
% Login disabled on line 66, until 'password' is set
% Login disabled on line 67, until 'password' is set
% Login disabled on line 68, until 'password' is set
% Login disabled on line 69, until 'password' is set
% Login disabled on line 70, until 'password' is set
Router(config-line)# password insta

Avoir un mot de passe dans la session de commande
Router> enable
Router# conf t
Router(config)# enable password demo

Configurer le DHCP sur un routeur
Router(config)# ip dhcp pool name10
Router(dhcp-config)# network 192.168.10.0 255.255.255.0
Router(dhcp-config)# ?
  default-router  Default routers
  dns-server      Set name server
  exit            Exit from DHCP pool configuration mode
  network         Network number and mask
  no              Negate a command or set its defaults
  option          Raw DHCP options
Router(dhcp-config)# dns-server 8.8.8.8
Router(dhcp-config)# default-router 192.168.10.254

Configurer une exclusion DHCP au routeur
Routeur> enable
Routeur# conf t
Router(config)# ip dhcp excluded-address 192.168.10.254

Voir la table DHCP

Router# show ip dhcp binding
IP address       Client-ID/              Lease expiration        Type
                 Hardware address
192.168.10.1     0002.1601.62E7           --                     Automatic

Configurer le NAT

Router> enable
Router# conf t
Router(config)# interface serial 0/0
Router(config-if)# ip nat outside
Router(config-if)# no sh
Router(config-if)# exit
Router(config)# interface fastEthernet 0/0
Router(config-if)# ip nat inside
Router(config-if)# exit
Router(config)# ip nat inside source static ?
  A.B.C.D  Inside local IP address
  tcp      Transmission Control Protocol
  udp      User Datagram Protocol
Router(config)# ip nat inside source static 192.168.10.1

Voir les IP NAT
Router# show ip nat translations

Désactiver la vérification des commandes erronées

Router# conf t
Router(config)# no ip domain lookup

Voir le contenue de la flash

Router# show flash:
System flash directory:
File  Length   Name/status
  4   5571584  c2600-i-mz.122-28.bin
[5571584 bytes used, 58444800 available, 64016384 total]
63488K bytes of processor board System flash (Read/Write)

Supprimer le contenue de la flash

Router# delete  flash:c2600-i-mz.122-28.bin
Delete filename [c2600-i-mz.122-28.bin]?
Delete flash:/c2600-i-mz.122-28.bin? [confirm]

Redémarrer le routeur
Router# reload

Configurer un fastEthernet

Router(config)# interfaces fastEthernet 0/0
Router(config-if)# description connection LANB
Router(config-if)# ip address 192.168.1.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit

Configurer un Serial

Router(config)# interfaces serial 0/0
Router(config-if)# description connection routeur2
Router(config-if)# ip address 192.168.1.125
Router(config-if)# no shutdown
Router(config-if)# exit


Router(config)# ip route 0.0.0.0 0.0.0.0 <address_routeur_router>

Configuration des services DHCP

Router> enable
Router# conf t
Router(config)# ip dhcp pool LAN-address
Router(config)# network 172.16.0.0 255.255.0.0
Router(config)# ip dhcp excluded-address 172.16.1.100 172.16.1.103
Router(dhcp-config)# domain-name cisco.com
Router(dhcp-config)# dns-server 172.16.1.103 172.16.2.103
Router(dhcp-config)# default-routeur 172.16.1.100
Router(dhcp-config)# lease {days [hours] [minutes]| infinite}
Router(dhcp-config)# end
Router# show running-config
!
ip dhcp pool LAN-address
domain-name cisco.com
network 172.16.0.0 255.255.0.0
ipdhcp excluded-address 172.16.1.100 172.16.1.103
dns-server 172.16.1.103 172.16.2.103
default-routeur 172.16.1.100
lease infinite
!

Configuration des routes statiques
Router> enable
Router# conf t
Router(config)# ip route [réseau_destination] [masque_sous_réseau] [adresse_passerelle]
ou alors :
Router(config)# ip route [réseau_destination][masque_sous_réseau][interface_sortie]

Configuration de la fonction NAT Statique

Router> enable
Router# conf t
Router(config)# interface fastethernet 0/0
Router(config-if)# ip address 172.31.232.182 255.255.255.0
Router(config-if)# ip nat inside
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface serial 0/0
Router(config-if)# ip address 209.165.201.1 255.255.255.0
Router(config-if)# ip nat outside
Router(config-if)# no shitdown 
Router(config-if)# exit
Router(config)# ip nat inside source static 172.31.232.14 209.165.202.130
Router(config)# exit
Router# show running-config
!
interface fastethernet 0/0
ip address 172.31.232.182 255.255.255.0
ip nat inside
!
!
interface serial 0/0
ip address 209.165.201.1 255.255.255.252
ip nat outside
ip nat inside source 172.31.232.182 209.165.202.130
!

Sauvegarde de la configuration

Router> enable
Router# copy startup-config tftp
Adresse du serveur ? 172.31.1.203
Nom du fichier ? save21122011
? Yes
? Yes 
[...]

Sauvegarde de la configuration en cours

Router> enable
Router# copy running-config tftp
Adresse du serveur ? 172.31.1.203
Nom du fichier ? save22122011
? Yes
? Yes 
[...]

Restaure une configuration

Router> enable
Router# copy tftp running-config
Server ? 172.31.1.203
nom du fichier ? save22122011
Router# copy run start

Encapsulation PPP

Router> enable
Router# conf t
Router# interface serial 0/0/0
Router(config-if)# ip address 192.168.2.1125 255.255.255.0
Router(config-if)# encapsulation ppp
Router(config-if)# no shutdown

Information sur le Cisco Discovery Protocol

Router# show cdp neighbors
ou alors :
Router# show cdp neighbors detail

Désactiver/Réactiver l'utilisation de CDP
De manière globale :
Router(config)# no cdp run
Sur une interface :
Router(config-if)# no cdp enable
Réactiver CDP :
Router(config)# cdp run
Router(config_if)# cdp enable

Voir la table de routage
Router# show ip route

Configuration du protocole RIP

Router> enable
Router# conf t
Routeur(config)# router rip
Routeur(config-router)# version 2
Routeur(config-router)# network 192.168.1.0
Routeur(config-router)# network 192.168.0.0
Routeur(config-router)# network 172.16.0.0
Routeur(config-router)# exit

Vérification du protocole RIP

Router# show ip route
Router# show ip protocol
Router# debug ip rip

Commande de vérification
Vérifier que les routes reçues sont installée dans la table de routage :
Routeur# show ip route 
Afficher des informations sur la configuration actuelle pour les protocoles :
Routeur# show running-config 
Vérifier que les interfaces sont activées et opérationnelles :
Routeur# show interfaces
Afficher les réseaux annoncés dans la mise à jour, dès que celles-ce sont envoyées et reçues :
Routeur# debug ip rip
Vérifier que les protocoles de routage s’exécute et annonce les réseaux appropriés :
Routeur# show ip protocols

Routage sur internet
Les protocoles IGP (Interior Gateway Protocols) permettent d’échanger des informations de routage au sein d’un système autonome ou d’une organisation individuelle. L’objectif d’un protocole de routage intérieur consiste à trouver le meilleur chemin possible sur le réseau interne. Les protocoles IGP sont exécutés sur les routeurs internes à l’organisation. RIP, EIGRP et OSPF sont des IGP.


Les protocoles de routage extérieur (EGP) quant à eux, permettent à deux systèmes autonomes différents d’échanger des informations de routage. Étant donné que chaque système autonome est géré par une administration différente et qu’il peut utiliser différents protocoles intérieurs, les réseaux doivent utiliser un protocole capable de communiquer entre différents systèmes. Le protocole EGP sert de traducteur pour que les informations de routage externe soient correctement interprétées à l’intérieur de chaque réseau de système autonome.


Les protocoles EGP s’exécutent sur les routeurs externes. Ce sont des routeurs qui sont situés à la périphérie d’un système autonome. Les routeurs externes sont également appelés passerelles externes ou routeurs de périphérie.


Contrairement aux routeurs internes qui échangent des routes individuelles entre eux à l’aide de protocoles IGP, les routeurs externes échangent des informations concernant le moyen d’atteindre différents réseaux à l’aide de protocoles externes. Les protocoles de routage externes cherchent à trouver le meilleur chemin via Internet sous forme de série de systèmes autonomes.


Le protocole de routage externe le plus courant sur Internet aujourd’hui est le protocole BGP (Border Gateway Protocol). On estime que 95 % des systèmes autonomes utilisent ce protocole. La version la plus courante du protocole BGP est la version 4 (BGP-4) dont la description la plus récente figure dans la spécification RFC 4271.
Lorsqu’un FAI place un routeur chez un client, il le configure habituellement à l’aide d’une route statique par défaut vers le FAI. Parfois cependant, le FAI souhaite inclure le routeur dans son système autonome et son protocole BGP. Il est alors nécessaire de configurer le routeur installé sur le site du client en le dotant des commandes nécessaires à l’activation du protocole BGP.

Protocole BGP
La première étape de l’activation du protocole BGP sur un routeur consiste à configurer le numéro de système autonome. Cette opération s’effectue à l’aide de la commande suivante :

Routeur# routeur bgp [numéro_AS]


L’étape suivante consiste à identifier le routeur du FAI qui est le voisin BGP avec lequel le routeur CPE (Customer Premise Equipment) échange des informations. La commande permettant d’identifier le routeur voisin est la suivante :

Routeur# neighbor [adresse_IP] remote_as [numéro_AS]


Lorsqu’un client de FAI possède son propre bloc d’adresses IP enregistrées, il peut souhaiter que les routes vers certains de ses réseaux internes soient connues sur Internet. Pour utiliser le protocole BGP afin d’annoncer une route interne, il faut identifier l’adresse du réseau. Le format de cette commande est le suivant :

Routeur# network [adresse_réseau]


Une fois l’équipement du site client installé et les protocoles de routage configurés, le client dispose à la fois de la connectivité locale et de la connectivité Internet. Le client est maintenant en mesure de participer pleinement aux autres services proposés par le FAI.


Les adresses IP utilisées pour le protocole BGP sont des adresses routables normalement enregistrées qui identifient des organisations uniques. Dans les très grandes organisations, il est possible d’utiliser des adresses privées dans le processus BGP. Sur Internet, le protocole BGP ne doit jamais être utilisé pour annoncer une adresse de réseau privé.